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1 ADCP Installation Overview 

1.1 Sensor Equipment 

The following sensors are installed on the RV ‘Heincke’ (Table 1). 

Table 1: Sensor specification 

Sensor Model Details from Manufacturer 

ADCP 600 kHz 

- vessel mounted - 

Teledyne RDI 

Workhorse 

Mariner 

Range: 50 m 
Vertical resolution cell size: 0.5 - 4 m 
Velocity accuracy: 0.3 % of the water velocity relative 
to the ADCP ± 0.3 cm/s 
Velocity resolution: 0.1 cm/s 
Number of depth cells: 1 - 128 

Inertial Navigation 

System 

(INS) 

IXSea Phins Heading accuracy: 0.05 deg (without aiding) 
Roll, Pitch accuracy: 0.01 deg 
Heave accuracy: 5 cm or 5% 

Primary Positioning 

Unit 

Trimble SP461 Primary Positioning system DGPS 
0.5 - 3 m accuracy 

Backup Positioning 

Unit 

Saab R5 Secondary Positioning system DGPS 
1 - 3 m accuracy 

1.2 Sensor Structure 

Table 1 shows the sensor structure of the ADCP hardware and shows the installation in the 

laboratory. The 600 kHz transducers are hull mounted. The deck units of both ACDPs 

(Teledyne RDI Ocean Surveyor 150kHz and Teledyne RDI Workhorse Mariner 600 kHz) are 

permanently installed in the server rack next to the operator PC. The operator PC receives 

ADCP data from one ADCP deck unit at a time (no parallel operation!), position information 

from the Trimble DGPS receiver as well as attitude data (heading) from the IXSea PHINS III 

Inertial navigation system (INS). Recorded data should be regularly copied to the network 

shares of the XDC storage server. 

Figure 1 and Figure 2 show active connections for using different software (VmDas or 

WinRiver II) with the Teledyne RDI Workhorse Mariner 600 kHz. Figure 3 shows the 

installation in the laboratory. 
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Figure 1: Wiring diagram for using the ADCP with VmDas 

 
 
 

 

 

Figure 2: Wiring diagram for using the ADCP with WinRiver II 
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Figure 3: Photo showing the system in the lab 

1.3 Software 

The software VmDas (Vessel-mount data acquisition system) is used for data acquisition and 

configuration of the ADCP. The software WinADCP can be used for visualization and export 

of recorded raw data. Both software packages are installed on the ADCP operator PC.  

Alternatively, the software WinRiver II is installed. In the following, startup and storage is 

described for the recommended application VmDas. A short reference to the WinRiver II 

software can be found at the end of this manual. 

2 System Start-up 

This manual is created for the specific use of the Teledyne Workhorse Mariner 600 kHz 

ADCP on RV ‘Heincke’ and focuses on the most important parameters to be looked after 

during data acquisition. We recommend taking a look at the VmDas Quick Start Guide and 

VmDas User Guide additionally. 

2.1 Switch on ADCP 

1. Power up the ADCP operator PC (Figure 3, right) 

2. Power up the deck unit in the server rack (Figure 3, right) 
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2.2 System Test (BBTalk) 

Before you start a survey, you should perform a hardware system test. 
1. Start the BBTalk program from the desktop of the operator PC. 

2. Connect to the ADCP unit by selecting the settings: 

  

Figure 4: Define COM port and serial connection settings in BBTalk 

3. Select Options as shown below: 

 

Figure 5: Program settings in BBTalk 

4. To run the test, several commands need to be sent to the ADCP. 

5. Select the menu File → Send script file or press <F2>. 

6. Select the file C:\Program Files (x86)\RD Instruments\RDI Tools\TestWH.rds. 

7. This file contains the following set of commands for the ADCP which is now executed 

one after another (The Enter button can be pressed to skip the delays.): 

CR1, TS?, PS0, PS3, PA, PC2, PC1 

The results can be saved to a text file via copy & paste (see Appendix). 
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3 VmDas Acquisition Software 

The software VmDas is used for data acquisition and playback. 
1. Start the VmDas program from the desktop of the operator PC 

2. Select File → Collect Data and then import the default configuration settings using 

Options → Load. The default configuration is 

C:\ADCP\600kHz_WorkhorseMariner\config\600kHz_WorkhorseMariner_TCPIP.i

ni. 

3. The configuration settings should be checked before data acquisition. Enter the menu 

Options → Edit Data Options and edit the settings as described in the section 3.1 to 

3.11. 

4. After checking the settings carefully, start the data acquisition. Select the menu File 

→ Collect Data or press the  button at the upper left of the main window. The data 

recording starts immediately and the screen looks about the same as the screenshot 

in Figure 6. 

 

Figure 6: VmDas screen layout during data collection (raw display mode) 
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3.1 Communications Settings 

The Communications tab (in menu Options → Edit Data Options) configures the serial and 

network connections to the ADCP, the GPS, and the motion sensor. Make sure that the 

inputs correspond to those in Figure 7 (red rectangle). 

 

Figure 7: Required communication settings for 600 kHz ADCP (red circle) 

Please note: Due to several problems with the COM1 Port, the NMEA 1 Input (GPS input) 
has now been changed to TCP/IP (Figure 8). 

 

Figure 8: Changed NMEA 1 Input (GGA, VTG from Trimble DGPS) 
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3.2 ADCP Settings 

For the 600 kHz ADCP, only the option ADCP Setup from File is supported by VmDas. That 

means, changes to the desired resolution must be made in a text file (please do not overwrite 

the default file WH600_default_settings.txt). If bottom tracking is activated (default setting 

and recommended), the Ensemble Time should be set to Ping as fast as possible (Figure 

9). 

 

Figure 9: ADCP and auxiliary sensor setup 

  

not working with 
WorkHorse ADCP 
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3.3 Changes in the ADCP Setup File 

The setup file contains the following commands (Table 2) that can be modified by the user: 

Table 2: command description 

Command Description Default 

CR Retrieve Parameters CR1 

CF Flow Control CF11110 

BM Bottom Track Mode BM5 

BP Bottom-Track Pings Per Ensemble BP1 

BX Maximum Tracking Depth BX1500 

EA Heading Alignment EA03400 

EB Heading Bias EB0 

ED Depth of Transducer [decimeter] ED40 

ES Salinity [PSU] ES35 

EX Coordinate Transformation EX11111 

EZ Sensor Source EZ1111101 

WA False Target Threshold Maximum WA50 

WB Mode 1 Bandwidth Control WB0 

WD Data Out WD111100000 

WF Blank after Transmit [centimeter] WF200 

WN Number of Depth Cells WN23 

WP Pings Per Ensemble WP1 

WS Depth Cell Size [centimeter] WS200 

WV Ambiguity Velocity WV175 

TE Time Per Ensemble TE00:00:01.46 

TP Time Between Pings TP00:00.73 

CK Keep Parameters CK 

CS Start Pinging (Go) CS 

 

Only the settings marked red should be modified according to the desired range and 

resolution. WB0 stands for wide bandwidth with a high sample rate and a low profiling range, 

WB1 should be chosen for narrow bandwidth with a low sample rate and a high profiling 

range. Blank after transmit specifies the space between the transducer and the first depth 

cell. 

  



                                                                                                                                                     

 Page 11 of 22  

3.4 Recording Settings 

The Recording tab (in menu Options → Edit Data Options) configures the recording options 

for your survey/expedition. Choose an adequate name for your survey/expedition. Set the 

primary path for recorded files to C:\ADCP\600kHz_WorkhorseMariner\data as shown 

below. If a backup is desired, check Dual Output Directories and provide a path 

(H:\Scientist\data\ADCP). 

 

Figure 10: Recording settings; make sure to set correct output and backup directories. 
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3.5 Navigation Settings 

This tab configures the navigation input sources for the ship’s position and the ship’s speed 

over ground. Ensure the settings are as shown below: 

 

Figure 11: Required navigation input settings 
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3.6 Transformation Settings  

The reference beam 3 of the ADCP is mounted 45° relative to the ship’s longitudinal axis 

which has been detected by a bottom and water track measurement. Ensure this offset is 

given as the EA Heading Alignment Error in the configuration! 

The Transform tab configures heading and roll/pitch input sources as well as angular offsets 

for each parameter. Please ensure all settings are as shown in Figure 12. 

 

Figure 12: Required transformation settings 

  

45° 
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3.7 Averaging Settings  

This tab (in menu Options → Edit Data Options) configures the averaging of the ADCP raw 

data. Configure as shown in Figure 13 or adjust the settings according to your requirements. 

The settings will not affect the raw data. 

 

Figure 13: Averaging settings, adjustable to your requirements 

3.8 Data Screening Settings  

The Data Screening tab (in menu Options → Edit Data Options) configures the screening 

settings for the visualization of the ADCP raw data. Adjust these settings according to your 

requirements. 

You can set limits for RSSI (amplitude), correlation, percent good, error velocity, vertical 

velocity and fish screening. If the raw values are below the selected minimum limits the 

values will not be displayed nor included in the short time and long-time averages. The raw 

data is of course not affected by these settings. 
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3.9 User Exits 

In this tab it is recommended to check the Launch WinAdcp box as shown in Figure 14. 

 

Figure 14: Recommended User Exits settings 

3.10 Sim Inputs 

This tab shows options to replay already recorded data. For data collection (default) it should 

be configured as shown in Figure 15. 

 

Figure 15: Configuration for data collection 
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3.11 Short Term Averages (STA) in VmDas 

VmDas offers the possibility to display already averaged velocities (according to the 

averaging settings, Figure 13) on a map including the ship movement on a map (screenshot 

in Figure 16). Therefore, press the tab  in the toolbar. You can change the references / 

displayed velocities under Options → Edit Display Option (this will not affect the raw data 

collection). 

 

Figure 16: Screenshot of VmDas during data replay 
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4 WinADCP 

The WinADCP software can be used for visualization and export of the 

recorded ADCP data (screenshot in Figure 17). For a detailed description, 

please read the WinADCP User Manual for help on how to use the software. 

Load the *.ENX-File which contains all information. 

 

Figure 17: Screenshot of WinADCP during data replay 

4.1 Exporting Data 

Besides several displaying and replay features of the collected data, WinADCP is used to 

Export the data to ASCII-format. Before that, open the WinADCP Chart Options with a right-

mouse-click in either the Whole Set or Sub Set window (Figure 18). Here you can choose 

under Processing if the velocity is already corrected using the Bottom Track or the 

Navigation (VMDAS), or if it is not corrected (None). We recommend the not-corrected 

output, so you can choose during further processing the most suitable correction. 
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Figure 18: WinADCP Chart Options window 

The ASCII-export is done choosing Export in the menu and then select Series/Ancillary 

(Figure 19). Here, a selection can be made which bins should be exported and which primary 

data types (typically the zonal, meridional, and error velocities) and which ancillary data 

types should be exported (typically Bottom Track and Navigation data). If bottom track has 

been chosen as velocity reference, the exported velocities are already representing the true 

water velocities (i.e. ship movement corrected). 

 

Figure 19: Data export in WinADCP 
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5 WinRiver II 

For using WinRiver II, please refer to the manual stored on the operator PC. Here, only the 

communication setup is shown in the following figures. 

First, make sure the correct serial connections are set in the Peripheral Configuration 

Dialog (Figure 20). Select the COM-Port according to Figure 21 to Figure 23. 

 

 

Figure 20: Peripheral Configuration Dialog settings to connect GPS, external heading, 
and ADCP 

   

Figure 21: COM 1 settings 
(GPS) 

Figure 22: COM 3 settings 
(external heading) 

Figure 23: COM 6 settings 
(ADCP) 

 
After this, make sure to enter the Beam 3 misalignment of 45° in the Offsets window (Figure 
24 and Figure 25). 
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Figure 24: WinRiver II main window. Please check beam 3 misalignment and 
transducer depth (cf. next figure) for correct measurements 

 

Figure 25: WinRiver II properties window 

  

Click right 
mouse button 

here 

45° 
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Appendix 

BBTalk Test Result 

[BREAK Wakeup B] 

WorkHorse Mariner ADCP Version 52.40 

Teledyne RD Instruments (c) 1996-2010 

All Rights Reserved. 

>CR1 

[Parameters set to FACTORY defaults] 

>TS? 

TS 19/02/14,09:39:20 --- Time Set (yr/mon/day,hour:min:sec) 

>PS0 

  Instrument S/N:  22500 

       Frequency:  614400 HZ 

   Configuration:  4 BEAM, JANUS 

     Match Layer:  10 

      Beam Angle:  20 DEGREES 

    Beam Pattern:  CONVEX  

     Orientation:  DOWN 

       Sensor(s):  HEADING  TILT 1  TILT 2  TEMPERATURE 

Temp Sens Offset:  -0.13 degrees C 

 

    CPU Firmware:  52.40 [0] 

   Boot Code Ver:  Required:  1.16   Actual:  1.16 

    DEMOD #1 Ver:  ad48, Type:  1f 

    DEMOD #2 Ver:  ad48, Type:  1f 

    PWRTIMG  Ver:  85d3, Type:   7 

 

Board Serial Number Data: 

   82  00 00 07 BE E1 3D  09 DSP727-2001-03H 

   C4  00 00 07 BE DA 3B  09 PIO727-3000-00G 

   17  00 00 07 BE AA 57  09 REC727-1000-03E 

   48  00 00 07 BE E2 BF  09 CPU727-2011-00E 

>PS3 

Beam Width:   3.7 degrees 

 

Beam     Elevation     Azimuth 

  1         -70.14      270.14 

  2         -70.06       90.13 

  3         -70.01      359.87 

  4         -69.99      179.86 

 

Beam Directional Matrix (Down): 

  0.3398   -0.0008    0.9405    0.2417   

 -0.3412    0.0008    0.9400    0.2408   

  0.0008   -0.3419    0.9398   -0.2416   

 -0.0008    0.3424    0.9396   -0.2413   

 

Instrument Transformation Matrix (Down):    Q14: 

  1.4667   -1.4701   -0.0021    0.0047       24031  -24086     -35      77   

  0.0030   -0.0039   -1.4609    1.4620          49     -64  -23935   23954   

  0.2666    0.2655    0.2661    0.2657        4368    4350    4359    4353   

  1.0376    1.0335   -1.0369   -1.0355       17000   16933  -16989  -16965   

Beam Angle Corrections Are Loaded. 

>PA 

PRE-DEPLOYMENT TESTS 

 

CPU TESTS: 

  RTC......................................PASS 

  RAM......................................PASS 

  ROM......................................PASS 

RECORDER TESTS: 

  PC Card #0...............................NOT DETECTED 

  PC Card #1...............................NOT DETECTED 

DSP TESTS: 

  Timing RAM...............................PASS 

  Demod  RAM...............................PASS 

  Demod  REG...............................PASS 

  FIFOs....................................PASS 

SYSTEM TESTS: 

  XILINX Interrupts... IRQ3  IRQ3  IRQ3 ...PASS 

  Wide Bandwidth........................***FAIL*** 

  Narrow Bandwidth.........................PASS 
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  RSSI Filter...........................***FAIL*** 

  Transmit.................................PASS 

SENSOR TESTS: 

  H/W Operation............................PASS 

>PC2 

 

Press any key to quit sensor display ... 

 

All Sensors are Internal Only. 

Heading   Pitch    Roll   Up/Down    Attitude Temp   Ambient Temp   PRESSURE 

 46.26ø  -0.04ø  -0.41ø    Down          5.97øC         4.14øC         0.0 kPa 

>PC1 

 

 

BEAM CONTINUITY TEST 

 

When prompted to do so, vigorously rub the selected 

beam's face. 

 

If a beam does not PASS the test, send any character to 

the ADCP to automatically select the next beam. 

 

Collecting Statistical Data... 

  61  66  61  64 

 

Rub Beam 1 = PASS 

Rub Beam 2 = PASS 

Rub Beam 3 = PASS 

Rub Beam 4 = PASS 


