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1 ADCP Installation Overview 

1.1 Sensor Equipment 

The following sensors are installed on the RV ‘Heincke’ (Table 1). 

Table 1: Sensor specification 

Sensor Model Details from Manufacturer 

ADCP 150 kHz 

- vessel mounted - 

Teledyne RDI 

Ocean Surveyor 

Range: 400 m 
Vertical resolution cell size: 4 - 8 m 
Velocity accuracy: ± 1.0 % of the water velocity 
relative to the ADCP ± 0.5 cm/s 
Velocity resolution: 9 - 30cm/s 
Number of depth cells: 1 - 128 

Inertial Navigation 

System 

(INS) 

IXSea Phins Heading accuracy: 0.05 deg (without aiding) 
Roll, Pitch accuracy: 0.01 deg 
Heave accuracy: 5 cm or 5% 

Primary Positioning 

Unit 

Trimble SP461 Primary Positioning system DGPS 
0.5 - 3 m accuracy 

Backup Positioning 

Unit 

Saab R5 Secondary Positioning system DGPS 
1 - 3 m accuracy 

1.2 Sensor Structure 

Table 1 and Figure 1 show the sensor structure of the Teledyne RDI Ocean Surveyor 150 

kHz ADCP hardware and Figure 2 shows the installation in the laboratory. The 150 kHz 

transducer is hull mounted. The deck units of both ACDPs (Teledyne RDI Ocean Surveyor 

150 kHz and Teledyne RDI Workhorse Mariner 600 kHz) are permanently installed in the 

server rack next to the operator PC. The operator PC receives data from one ADCP deck 

unit at a time (no parallel operation!), position information from the Trimble DGPS receiver, 

as well as attitude data (heading) from the IXSea PHINS III Inertial navigation system (INS). 

Recorded data should be regularly copied to the network shares of the XDC storage server. 
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Figure 1: Wiring diagram 

 
 
 

 

Figure 2: Photo showing the system in the lab 
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1.3 Software 

The software VmDas (Vessel-mount data acquisition system) is used for data acquisition and 

configuration of the Teledyne RDI Ocean Surveyor 150 kHz ADCP. The software WinADCP 

can be used for visualization and export of recorded raw data. Both software packages are 

installed on the ADCP operator PC. 

 

Please note: On the operator PC, also the software WinRiver II is installed. WinRiver II does 

not support the Teledyne RDI Ocean Surveyor 150 kHz ADCP. Do not use WinRiver for this 

system, it is exclusively installed for use with the Teledyne RDI Workhorse Mariner. 

2 System Start-up 

This manual is created for the specific use of the Teledyne Ocean Mariner 150 kHz ADCP 

(ADCP in the following text) on RV ‘Heincke’ and focuses on the most important parameters 

to be looked after during data acquisition. We recommend to additionally check the VmDas 

Quick Start Guide and VmDas User Guide. 

2.1 Switch on ADCP 

1. Power up the ADCP operator PC (Figure 2, right) 

2. Power up the deck unit in the server rack (Figure 2, right) 
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2.2 System Test (BBTalk) 

Before you start a survey, you should perform a hardware system test. 

1. Start the BBTalk program from the desktop of the operator PC. 

2. Connect to the ADCP unit by selecting the settings: 

  

Figure 3: Define COM port and serial connection settings in BBTalk 

3. Select Options as shown below: 

 

Figure 4: Program settings in BBTalk 

4. To run the test, several commands need to be sent to the ADCP. 

5. Select the menu File → Send script file or press <F2>. 

6. Select the file C:\Program Files (x86)\RD Instruments\RDI Tools\ TestOS.rds. 

This file contains the following set of commands for the ADCP which is executed one 

after another (The Enter button can be pressed to skip the delays.): 

CR1, TS?, PS0, PA, PT3, PT6 

The results can be saved to a text file via copy & paste (see Appendix). 
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3 VmDas Acquisition Software 

The software VmDas is used for data acquisition and playback. 
1. Start the VmDas program from the desktop of the operator PC 

2. Select File → Collect Data and then import the default configuration settings using 

Options → Load. The default configuration is: 

C:\ADCP\150kHz_OceanSurveyor\config\150kHz_OceanSurveyor_TCPIP.ini. 

3. The configuration settings should be checked before data acquisition. Enter the menu 

Options → Edit Data Options and edit the settings as described in the section 3.1 to 

3.11. 

4. After checking the settings carefully, start the data acquisition. Select the menu File 

→ Collect Data or press the  button at the upper left of the main window. The data 

recording starts immediately and the screen looks about the same as the screenshot 

in Figure 5. 

 

Figure 5: VmDas screen layout during data collection (raw display mode) 
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3.1 Communications Settings 

The Communications tab (in menu Options → Edit Data Options) configures the serial or 

network connections to the ADCP, the GPS and the motion sensor. Make sure that the 

inputs correspond to those in Figure 6 (red rectangle). 

 

Figure 6: Required communication settings for 150 kHz ADCP 

Please note: Due to several problems with the COM1 Port, the NMEA 1 Input (GPS input) 

has now been changed to TCP/IP (Figure 7). 

 

Figure 7: Changed NMEA 1 Input (GGA, VTG from Trimble DGPS) 
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3.2 ADCP Settings 

For the 150 kHz ADCP, both ADCP Setup are possible in VmDas. For standard usage, we 

recommend however to use ADCP Setup from File. Please do not overwrite the default file 

OS150BBDEF_shortrange_broadband_highres.txt. If bottom tracking is activated (default 

setting and recommended), the Ensemble Time should be set to Ping as fast as possible 

(Figure 8). 

 

Figure 8: ADCP and auxiliary sensor setup 
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3.3 Changes in the ADCP Setup File 

The setup file contains the following commands (Table 2) that can be modified by the user: 

Table 2: command description 

Command Description Default 

CR Retrieve Parameters CR1 

CF Flow Control CF11110 

BM Bottom Track Mode BM5 

BP Bottom-Track Pings Per Ensemble BP1 

BX Maximum Tracking Depth BX1500 

EA Heading Alignment EA03400 

EB Heading Bias EB0 

ED Depth of Transducer [decimeter] ED40 

ES Salinity [PSU] ES35 

EX Coordinate Transformation EX11111 

EZ Sensor Source EZ1111101 

WA False Target Threshold Maximum WA50 

WB Mode 1 Bandwidth Control WB0 

WD Data Out WD111100000 

WF Blank after Transmit [centimeter] WF200 

WN Number of Depth Cells WN23 

WP Pings Per Ensemble WP1 

WS Depth Cell Size [centimeter] WS200 

WV Ambiguity Velocity WV175 

TE Time Per Ensemble TE00:00:01.46 

TP Time Between Pings TP00:00.73 

CK Keep Parameters CK 

CS Start Pinging (Go) CS 

 

Only the settings marked red should be modified according to the desired range and 

resolution. WB0 stands for wide bandwidth with a high sample rate and a low profiling range, 

WB1 should be chosen for narrow bandwidth with a low sample rate and a high profiling 

range. Blank after transmit specifies the space between the transducer and the first depth 

cell. 
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3.4 Recording Settings 

The Recording tab (in menu Options → Edit Data Options) configures the recording options 

for your survey/expedition. Choose an adequate name for your survey/expedition. Set the 

primary path for recorded files to C:\ADCP\150kHz_OceanSurveyor\data as shown 

inFigure 9. If a backup is desired, check Dual Output Directories and provide a path 

(H:\Scientist\data\ADCP). 

 

Figure 9: Recording settings; make sure to set correct output and backup directories. 
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3.5 Navigation Settings 

This tab configures the navigation input sources for the ship’s position and the ship’s speed 

over ground. Ensure the settings are as shown in Figure 10. 

 

Figure 10: Required navigation input settings 
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3.6 Transformation Settings  

The reference beam 3 of the ADCP is mounted 45° relative to the ship’s longitudinal axis 

which has been detected by a bottom and water track measurement. Ensure this offset is 

given as the EA Heading Alignment Error in the configuration! 

The Transform tab configures heading and roll/pitch input sources as well as angular offsets 

for each parameter. 

 

Figure 11: Required transformation settings 

  

45° 
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3.7 Averaging Settings  

This tab (in menu Options → Edit Data Options) configures the averaging of the ADCP raw 

data. Configure as shown in Figure 12 or adjust the settings according to your requirements. 

The settings will not affect the raw data. 

 

Figure 12: Averaging settings, adjustable to your requirements 

3.8 Data Screening Settings  

The Data Screening tab (in menu Options → Edit Data Options) configures the screening 

settings for the visualization of the ADCP raw data. Adjust these settings according to your 

requirements. 

You can set limits for RSSI (amplitude), correlation, percent good, error velocity, vertical 

velocity and fish screening. If the raw values are below the selected minimum limits the 

values will not be displayed nor included in the short time and long-time averages. The raw 

data is of course not affected by these settings. 
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3.9 User Exits 

In this tab it is recommended to check the Launch WinAdcp box as shown in Figure 13. 

 

Figure 13: Recommended User Exits settings 

3.10 Sim Inputs 

This tab shows options to replay already recorded data. For data collection (default) it should 

be configured as shown in Figure 14. 

 

Figure 14: Configuration for data collection 
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3.11 Short Term Averages (STA) in VmDas 

VmDas offers the possibility to display already averaged velocities (according to the 

averaging settings, Figure 12) on a map including the ship movement on a map (screenshot 

in Figure 15). Therefore, press the tab  in the toolbar. You can change the references / 

displayed velocities under Options → Edit Display Option (this will not affect the raw data 

collection). 

 

Figure 15: Screenshot of VmDas during data replay 
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4 WinADCP 

The WinADCP software can be used for visualization and export of the 

recorded ADCP data (screenshot in Figure 16). For a detailed description, please read the 

WinADCP User Manual for help on how to use the software. 

 

Figure 16: Screenshot of WinADCP during data replay 

4.1 Exporting Data 

Besides several displaying and replay features of the collected data, WinADCP is used to 

Export the data to ASCII-format. Before that, open the WinADCP Chart Options with a right-

mouse-click in either the Whole Set or Sub Set window (Figure 17). Here you can choose 

under Processing if the velocity is already corrected using the Bottom Track or the 

Navigation (VMDAS), or if it is not corrected (None). We recommend the not-corrected 

output, so you can choose during further processing the most suitable correction. 
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Figure 17: WinADCP Chart Options window 

The ASCII-export is done choosing Export in the menu and then select Series/Ancillary 

(Figure 18). Here, a selection can be made which bins should be exported and which primary 

data types (typically the zonal, meridional, and error velocities) and which ancillary data 

types should be exported (typically Bottom Track and Navigation data). If bottom track has 

been chosen as velocity reference, the exported velocities are already representing the true 

water velocities (i.e. ship movement corrected). 

 

Figure 18: Data export in WinADCP 
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Appendix 

BBTalk Test Result 

Ocean Surveyor Broadband/Narrowband ADCP 

Teledyne RD Instruments (c) 1997-2008 

All rights reserved. 

Firmware Version: 23.19   

 

>CR1 

[Parameters set to FACTORY defaults] 

>TS? 

TS 18/09/26,20:20:44.01 --------- Set System Date and Time 

>PS0 

       Frequency:  153600 HZ 

   Configuration:  4 BEAM, JANUS 

 Transducer Type:  ROUND 32x32 

  Beamformer Rev:  A02 or later 

      Beam Angle:  30 DEGREES 

    Beam Pattern:  CONVEX 

     Orientation:  DOWN 

    CPU Firmware:  23.19 

    FPGA Version:  A0 

         Sensors:  TEMP  SYNCHRO 

 

>PA 

RAM test...........PASS 

ROM test...........PASS 

Receive test.......PASS 

Bandwidth test.....PASS 

 

>PT3 

Correlation Magnitude: 

      Lag    Bm1      Bm2      Bm3      Bm4 

       0     1.00     1.00     1.00     1.00 

       1     0.82     0.81     0.82     0.81 

       2     0.46     0.42     0.43     0.39 

       3     0.16     0.12     0.11     0.05 

       4     0.02     0.02     0.05     0.08 

       5     0.05     0.05     0.04     0.07 

       6     0.08     0.05     0.04     0.03 

       7     0.10     0.05     0.07     0.01 

 

RSSI: 169 164 171 161  

 

PASSED 

 

>PT6 

Receive Bandwidth: 

..............................           

  Expected     Bm1    Bm2    Bm3    Bm4 

  --------    -----  -----  -----  ----- 

    15500     13272  14711  14456  14651 

 

PASSED 


